VCSA 7.0 Backup via SMB fails

This post was originally published on this site

Hello there,

 

I have enrolled a brand new VCSA 7.0 to start of fresh without carrying around any legacy stuff.

Works like a charm. Then I tried setting up automated backup via SMB to my backup server, let’s say fileserver.example.comvcenter

 

The first backup runs fine, creating the subfolder structure fileserver.example.comvcentervCentersn_srv-vctr-01.example.comS_7.0.0.10700_20200915-015904_

Howaver, any subsequent backup – scheduled as well as manually – will fail.

Diggind through the logs, i found the following behaviour:

 

2020-09-18T01:59:29.258 [20200918-015903-16749653] [MainProcess:PID-53557] [MountedFSStorageIOLib::_run_timed_cmd:MountedFSStorageIOLib.py:130] ERROR: Cmd ['/usr/bin/mount', '-t', 'cifs', '//fileserver.example.com/vsphere/vCenter/sn_srv-vctr-01.example.com/S_7.0.0.10700_20200918-015903_/', '/storage/remote/backup/cifs/fileserver.example.com/pATRdVP7/wZS2BZAQ', '-o', 'rw,credentials=/tmp/tmp2qycn_51'] failed. rc: 32, stdout: , stderr: mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

2020-09-18T01:59:29.259 [20200918-015903-16749653] [MainProcess:PID-53557] [MountedFSStorageIOLib::mount:MountedFSStorageIOLib.py:229] INFO: Failed to mount the cifs share //fileserver.example.com/vsphere/vCenter/sn_srv-vctr-01.example.com/S_7.0.0.10700_20200918-015903_/ at /storage/remote/backup/cifs/fileserver.example.com/pATRdVP7/wZS2BZAQ. Err- rc: 32, out=, err=mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

2020-09-18T01:59:29.259 [20200918-015903-16749653] [MainProcess:PID-53557] [BackupManager::main:BackupManager.py:621] ERROR: BackupManager encountered an exception: Plugin error occurred. ErrCode: 150, Args: ()

 

I tried to do the mount manually, created the corresponding credential file and received the following:

root@srv-vctr-01 [ /tmp ]# /usr/bin/mount -t cifs //fileserver.example.com/vsphere/vCenter/sn_srv-vctr-01.example.com/S_7.0.0.10700_20200930-071204_/ /storage/remote/backup/cifs/fileserver.example.com -o rw,credentials=/tmp/tmp4stl70fq -vvv
domain=
mount.cifs kernel mount options: ip=10.7.13.128,unc=fileserver.example.comvsphere,user=svc-vsphere-backup,prefixpath=vCenter/sn_srv-vctr-01.example.com/S_7.0.0.10700_20200930-071204_/,pass=********
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

 

It’s obvious that the backup job tries to mount a directory whithin the share that does not exist. Mounting the share and/or existing subfolders is possible, so no trouble with user/password (as I thought first):

root@srv-vctr-01 [ /tmp ]# /usr/bin/mount -t cifs //fileserver.example.com/vsphere/vCenter/sn_srv-vctr-01.example.com/ /storage/remote/backup/cifs/fileserver.example.com -o rw,credentials=/tmp/tmp4stl70fq -vvv
domain=
mount.cifs kernel mount options: ip=10.7.13.128,unc=fileserver.example.comvsphere,user=svc-vsphere-backup,prefixpath=vCenter/sn_srv-vctr-01.example.com/,pass=********

 

Has anyone experienced or even resolved this before? Any hints on further debugging?

 

Thank you all in advance and best regards,

Martin

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.