VCSA 6.7 install OVF Tool Failed to transfer “Bad return code from POST request: 404”

This post was originally published on this site

Hoping someone can help me here.  Doing a new deploy on a single ESXi 6.7 host (build 16316930)  using VMWare-VCSA-all-6.7.0-15132721. All DNS is setup locally and both ESXi host and VCSA resolve/ping using FQDN and short name. OVF log reports teh following lines…

 

2020-08-19T14:32:58.270-04:00 verbose OVFTool[10032] [Originator@6876 sub=Default] Initializing new curl session

2020-08-19T14:32:58.274-04:00 warning OVFTool[10032] [Originator@6876 sub=Default] No Proxy Certificate specified.

2020-08-19T14:32:58.274-04:00 verbose OVFTool[10032] [Originator@6876 sub=Default] Parsing URL…

2020-08-19T14:32:58.274-04:00 verbose OVFTool[10032] [Originator@6876 sub=Default] https://10.0.0.41:443/ha-nfc/520242ad-fdf2-7358-0579-f7d0def54b76/vca-1-0.vmdk is redirected to https://10.0.0.41/ha-nfc/520242ad-fdf2-7358-0579-f7d0def54b76/vca-1-0.vmdk

2020-08-19T14:32:58.274-04:00 verbose OVFTool[10032] [Originator@6876 sub=Default] Changing HttpWriterFactory path to https://10.102.0.41/ha-nfc/520242ad-fdf2-7358-0579-f7d0def54b76

2020-08-19T14:32:58.291-04:00 verbose OVFTool[10032] [Originator@6876 sub=Default] Closing image source and targets

2020-08-19T14:32:58.291-04:00 verbose OVFTool[10032] [Originator@6876 sub=Default] Bad return code from POST request: 404

2020-08-19T14:32:58.291-04:00 error OVFTool[10032] [Originator@6876 sub=Default] Error closing image-target

 

Packet capture shows the installer closing the connection with a RST (reset) after the “Bad return code” event.

 

Any help here would be appreciated…. I have tried both GUI and CLI install

 

installer log displays the following…

 

2020-08-19 18:32:56,418 – vCSACliInstallLogger – INFO – OVF Tool: Opening OVA source: H:vcsa-cli-installerwin32….vcsaVMware-vCenter-Server-Appliance-6.7.0.42000-15132721_OVF10.ova

2020-08-19 18:32:56,446 – vCSACliInstallLogger – INFO – OVF Tool:

The manifest does not validate

2020-08-19 18:32:56,583 – vCSACliInstallLogger – INFO – OVF Tool:

Opening VI target: vi://root@10.0.0.41:443/

2020-08-19 18:32:57,432 – vCSACliInstallLogger – INFO – OVF Tool:

Deploying to VI: vi://root@10.0.0.41:443/

2020-08-19 18:33:03,293 – vCSACliInstallLogger – INFO – OVF Tool: Transfer Failed                      

2020-08-19 18:33:03,320 – vCSACliInstallLogger – INFO – OVF Tool: Transfer Failed                      

2020-08-19 18:33:03,346 – vCSACliInstallLogger – INFO – OVF Tool:

Error: Failed to send http data

2020-08-19 18:33:05,471 – vCSACliInstallLogger – INFO – OVF Tool:

Completed with errors

2020-08-19 18:33:05,499 – vCSACliInstallLogger – ERROR – Deployment failed. OVF Tool return error code: 1

 

Any help would be appreciated…. Thank you in advance.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.