NMP: nmp_ResetDeviceLogThrottling in vmkernel log

This post was originally published on this site

Hello all….  After updating to the latest 5.5 patches we started seeing some messages repeating at different times (no time pattern) in the vmkernel log on all of our hosts.  The message is:

 

cpu45:33681)NMP: nmp_ResetDeviceLogThrottling:3311: Error status H:0x0 D:0x2 P:0x0 Sense Data: 0x5 0x20 0x0 from dev “mpx.vmhba32:C0:T0:L0” occurred 2 times(of 0 commands)

 

These messages repeat all day every day.  We boot from a supported SD card and the message indicates the USB device is to blame.  I opened a ticket with VMware, they stated that the messages are benign and nothing to worry about and are related to an updated SCSI driver in the patches we applied.  Basically the message is indicating that vmware is sending sense data to the USB controller which it does not understand and is sending back an illegal request.  Their suggestion was to reach out to HP for a firmware update. (we are at the latest FW on all hosts and I have tried backing down the FW to see if that would help) I have done that however I’m in the midst of a pissing match between VMware and HP both blaming each other for the fix so I’m turning to the community for help.

 

We have a mix of HPE DL380G8 & G9, and a spattering of ML350s at remote offices.  All of the updated servers are logging this message.

 

While I appreciate that the messages are benign they are causing noise in the logs and I’d like to figure out a way to 1) fix the issue (ideally) or 2) suppress the messages and 3) validate that the messages are indeed benign.

 

Are others seeing these same messages in their logs?  Given we have seen this on multiple hosts across multiple generations of HPE servers I’m inclined to believe others are seeing this as well?

 

To add to it, we recently purchased several DL360 Gen10 servers running 6.5.  All of those servers boot from SD card as well and log a similar message:

 

cpu40:65665)NMP: nmp_resetDeviceLogThrottling:3348 last error status from device “evi.00e04c20202020” repeated 2 times

cpu43:65665_NMP: nmp_ThrottleLogForDevice:3647 Cmd 0x9e (0x439d423a9200, 0) to dev “evi.00e04c20202020” on path “vmhba32″C0:T0:Lo” Failed: H0x7 D0x0 P:0X0

 

Thanks in advance for any advice on resolving this.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.