Importing 3rd party jar vcenter version incompatibility problem

This post was originally published on this site

Hello,

I develop a vCenter plugin which imports 3rd party jar files. I’ve run into a vCenter version incompatibility. As of around either late 6.7u2 or 6.7u3, my plugin no longer registers successfully. I am unsure of what I need to do or change in order to get it working on these newer vCenter versions, and why it would only throw these errors on the newer versions. An example of the error is listed below.

 

vsphere_client_virgo.log:[2020-05-16T00:19:58.509Z] [ERROR] vc-extensionmanager-pool-235  com.vmware.vise.extensionfw.plugins.impl.PluginStatusServiceImpl DEPLOYMENT_FAILED: Error deploying plugin package com.hpe.vnsui:1.4.9.0. Reason: Deployment error. java.io.IOException: The bundle at /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/com.hpe.vnsui-1.4.9.0/plugins/httpcore-4.4.9.jar should have Bundle-SymbolicName and Bundle-Version headers in its MANIFEST.MF

 

Any help would be appreciated. Thank you.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.