Get-SpbmReplicationGroup taking upwards of 10 minutes to complete

This post was originally published on this site

I am trying to write some automation or at least audit scripting to make sure my VMs are falling into the correct storagepolicy and replication group, however trying to gather the replication groups associated with a specific storage policy or gathering the replication group that is assigned to a VM and its respective storage policy takes about 10 minutes to complete. where as just getting storage policies in general (Get-SpbmStoragePolicy or Get-SpbmEntityConfiguration) takes less than a second. That long of a wait doesnt feel write and Im not sure where to turn if I wanted to script this out. also when it returns the replication group I get the below error, I just prefer gridview for testing but using it or not same time outcome

 

#this completes in 1 second

$storagePolicy = Get-SpbmStoragePolicy | Out-GridView -Title “Select a Policy” -Outputmode “Single”

 

#this will complete in about 10-15 minutes and with the below error

$RepPolicy = $storagePolicy | Get-SpbmReplicationGroup | Out-GridView -Title “Select a Pure Protection Group Policy” -Outputmode “Single”

 

Get-SpbmReplicationGroup : 9/15/2020 9:13:54 AM Get-SpbmReplicationGroup SMS runtime fault on server ‘/VIServer=USER@vCenter:443/’: Unknown server error. See the event log for details.

At line:1 char:31

+ $RepPolicy = $storagePolicy | Get-SpbmReplicationGroup | Out-GridView …

+                               ~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : InvalidArgument: (:) [Get-SpbmReplicationGroup], ViError

    + FullyQualifiedErrorId : Storage_Impl_ReplicationServiceImpl_RGFault,VMware.VimAutomation.Storage.Commands.Cmdlets.Spbm.Replication.GetSpbmReplicationGroup

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.