“Cycle Through Multiple Monitor” broken for triple monitor setup on Workstation Player 16

This post was originally published on this site

VM: Manjaro Linux (Kernel 5.8)

Host: Windows 10 2004 Pro 64bit

I just upgraded to VMWare Workstation Player 16 (from 15). I have a triple monitor setup (two external 1080p monitors connected to laptop with 1080p display). Before the upgrade I was able to use the triple monior setup inside the VM by selecting a layout from “Cycle Multiple Displays”, but now selecting a layout from the list does not do anything.

Strangely enough multi monitor works when I disable any one of the three displays, and try to use a dual monitor setup.

One more observation: I tried to look into the mksSandbox logs, and I found that it refers to the other two displays as “DISPLAY 4” and “DISPLAY 5” instead of dispay 2, 3. Maybe this might have something to do with the issue.

2020-09-30T01:24:05.585+05:30| mks| I005:    Display: 0 size: 1920×1080  position: (0, 0) name: .DISPLAY1 

2020-09-30T01:24:05.585+05:30| mks| I005:    Display: 3 size: 1920×1080  position: (1920, 0) name: .DISPLAY4 

2020-09-30T01:24:05.585+05:30| mks| I005:    Display: 4 size: 1080×1920  position: (-1080, -232) name: .DISPLAY5 

Have attached mksSandbox*.log and vmware*.log as a zip.

This is a similar thread with exact same issue:Re: Multiple monitors not working with vmware workstation player 16 

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.