Could not get vmci driver version: The handle is invalid.

This post was originally published on this site

I’m trying to create a new VM with VMWare Workstation 15.5.2. It seems to create it, but when i tried to power on the virtual machine i get the error

 

Could not get vmci driver version: The handle is invalid.

You have an incorrect version of driver ‘vmci.sys’. Try reinstalling VMware Workstation.

Module ‘DevicePowerOn’ power on failed.

Failed to start the virtual machine.

 

Information of my system:

– OS guest: Windows 10 Pro, version 10.0.18362

– Processor: Intel Xeon E3-1505M @ 3GH, 4 cores

 

I tried the following:

– Uninstall VMWare 15.5.2, restart the machine and try to install again 15.5.2 –> The problem is there, it doesn’t work

– Uninstall VMWare 15.5.2 and install 15.5.6 –> It’s impossible to install this version, i don’t know wich one is the error, because there is no information in any place

– Install again VMWare 15.5.2 and tried to upgrade to 15.5.6 –> I get the error: “install of vmware workstation pro failed. contact vmware support or your system administrator. “

– I tried to look for “vmci.sys” in the system, and there is only one vmci.sys in the system, in “C:Program FilesCommon FilesVMwareDriversvmcideviceWin8”, File version 9.8.16.0 build 14168184

 

Personally, this is very frustrating and i started to hate VMWare….

 

Is there any solution to this problem?

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.